$re = '/.*_(\d+)_.*$/m';
$str = 'SYND_YAHOO_7BEST_RANKADDITIONS_268_2357425';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);