$re = '/[^\/]+(?=\/?$)/m';
$str = 'http://dtarchive/directory/ag/book
http://dtarchive/main/child/directory/en/paper/
http://dtarchive/sidir/sichild/path/si/mag
http://dtarchive/lkdir/lkchild/path/lk/mz/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);