re = /[^\/]+(?=\/?$)/m
str = 'http://dtarchive/directory/ag/book
http://dtarchive/main/child/directory/en/paper/
http://dtarchive/sidir/sichild/path/si/mag
http://dtarchive/lkdir/lkchild/path/lk/mz/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end