using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<textarea.*?name=""xxx"".*?id=""xxx"".*?\/>([^<]+)<\/textarea>";
string input = @"<textarea name=""xxx"" id=""xxx"" />this is value</textarea>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}