re = /<textarea.*?name="xxx".*?id="xxx".*?\/>([^<]+)<\/textarea>/
str = '<textarea name="xxx" id="xxx" />this is value</textarea>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end