use strict;
my $str = '( comment_approved = \'0\' OR comment_approved = \'1\' ) AND ( (CAST(wp_72423799_commentmeta.meta_value AS SIGNED) >= \'1409095998\') ) AND (wp_72423799_commentmeta.meta_key = \'o2_comment_gmt_modified\' )
';
my $regex = qr/(comment_approved\s=\s\'(?:1|0)\')|\(\s(comment_approved\s=\s'0'\sOR\scomment_approved\s=\s'1')\s\)/p;
my $subst = '( $1$2 OR comment_approved = \\\'trash\\\' )';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";