using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\$?\d{1,3}(?:,?\d{3})*(?:\.\d{2})?|\.\d{2})?$";
string input = @".40";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}