package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\$?\d{1,3}(?:,?\d{3})*(?:\.\d{2})?|\.\d{2})?$`)
var str = `.40`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}