package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\.?\d?\d?%?$`)
var str = `21%
21
1.21
0.21
twenty
2
2%
1.21%
21percent`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}