$re = '/^\d+\.?\d?\d?%?$/m';
$str = '21%
21
1.21
0.21
twenty
2
2%
1.21%
21percent';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);