#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Foo\n=+\n((.+)(?:\n-+\n))+"
Local $sString = "Foo" & @CRLF & _
"=================" & @CRLF & _
"REKJH jdhskd sjdhs sjdhjshd jshdjdh" & @CRLF & _
"----------------------" & @CRLF & _
"DHKJ DJHDJHDJ DJHDJ ff" & @CRLF & _
"-----------------------" & @CRLF & _
"REKJH jdhskd sjdhs sjdhjshd jshdjdh" & @CRLF & _
"----------------------" & @CRLF & _
"DHKJ DJHDJHDJ DJHDJ fff" & @CRLF & _
"-----------------------" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")