using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Foo\n=+\n((.+)(?:\n-+\n))+";
string input = @"Foo
=================
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ ff
-----------------------
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ fff
-----------------------
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}