const regex = /(.*?)(static\.parastorage\.com)(.*?)\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(static\\.parastorage\\.com)(.*?)\\)$', 'gm')
const str = `url(//static.parastorage.com/services/santa-resources/resources/viewer/user-site-fonts/fonts/Japanese/Matisse/v1/WAT-MatisseProN-DB.woff2)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}