$re = '/(.*?)(static\.parastorage\.com)(.*?)\)$/m';
$str = 'url(//static.parastorage.com/services/santa-resources/resources/viewer/user-site-fonts/fonts/Japanese/Matisse/v1/WAT-MatisseProN-DB.woff2)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);