const regex = /^
(?:
\d{1,4}|
\d{4}-|
\d{4}-[01]|
\d{4}-(?:0[1-9]|1[0-2])|
\d{4}-(?:0[1-9]|1[0-2])-|
\d{4}-(?:0[1-9]|1[0-2])-[0-3]|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s[0-2]|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s(?:2[0-3]|[01]\d)|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s(?:2[0-3]|[01]\d):|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s(?:2[0-3]|[01]\d):[0-5]|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s(?:2[0-3]|[01]\d):[0-5]\d|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s(?:2[0-3]|[01]\d):[0-5]\d:|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s(?:2[0-3]|[01]\d):[0-5]\d:[0-5]|
\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\d|3[0-1])\s(?:2[0-3]|[01]\d):[0-5]\d:[0-5]\d
)
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?:
\\d{1,4}|
\\d{4}-|
\\d{4}-[01]|
\\d{4}-(?:0[1-9]|1[0-2])|
\\d{4}-(?:0[1-9]|1[0-2])-|
\\d{4}-(?:0[1-9]|1[0-2])-[0-3]|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s[0-2]|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s(?:2[0-3]|[01]\\d)|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s(?:2[0-3]|[01]\\d):|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s(?:2[0-3]|[01]\\d):[0-5]|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s(?:2[0-3]|[01]\\d):[0-5]\\d|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s(?:2[0-3]|[01]\\d):[0-5]\\d:|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s(?:2[0-3]|[01]\\d):[0-5]\\d:[0-5]|
\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|[12]\\d|3[0-1])\\s(?:2[0-3]|[01]\\d):[0-5]\\d:[0-5]\\d
)
$', 'gm')
const str = `2
-
20
20a
201
2018
2018-
2018-0
2018-02
2018-02-
2018-02-1
2018-02-1@
2018-02-12
2018-02-12
2018-02-12 0
2018-02-12 00
2018@02-12 00:
2018-02-12 00:
2018-02-12 00:5
2018-02-12 00:55
2018-02-12 00:55:
2018-02-12 00:55:2
2018-02-12 00:55:2z
2018-02-12 00:55:22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}