$re = '/https:\/\/github\.com\/+([A-Za-z-]+)\/+([A-Za-z-]+)\/pull\/+([0-9]+)/m';
$str = 'https://github.com/vassilidev-test/tetst-test/pull/150';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);