// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/github\.com\/+([A-Za-z-]+)\/+([A-Za-z-]+)\/pull\/+([0-9]+)").unwrap();
let string = "https://github.com/vassilidev-test/tetst-test/pull/150";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}