using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"www\.mysite\.com\(test|test2|foo\/bar\/[^\?]\w+";
string input = @"www.mysite.com/foo/bar/
www.mysite.com/foo/bar/?u=90
www.mysite.com/foo/bar/mmm-nnn/?u=preview
www.mysite.com/foo/bar/ppp
www.mysite.com/foo/bar/?sd=100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}