package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)www\.mysite\.com\(test|test2|foo\/bar\/[^\?]\w+`)
var str = `www.mysite.com/foo/bar/
www.mysite.com/foo/bar/?u=90
www.mysite.com/foo/bar/mmm-nnn/?u=preview
www.mysite.com/foo/bar/ppp
www.mysite.com/foo/bar/?sd=100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}