using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([_0-9a-zA-Z-]+\/)?(wp-(content|admin|includes).*)";
string input = @"wp-content/plugins/example.php
subsite1/wp-content/plugins/example.php
subsite2/wp-content/plugins/example.php";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}