import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "newTask[\\{] taskId\\\"(?<id>\\d{1,4})\\\", username\\\"(?!(?i:bahman\\\"))\\w{7,16}\\d\\\", isValid\\\"(?<isitthough>no|yes)\\\", name\\\"[\\w\\s]*\\\", address\\\"(?<address>[\\w\\s]+-\\d{8,10})\\\", date\\\"(?<date>\\d{8})\\\", info\\\"(?<info>[^\\\"]*)\\\", price\\\"(?<price>\\d+\\.?\\d*)\\\"";
final String string = "newTask{ taskId\"1\", username\"AyesItsGoood4\", isValid\"yes\", name\"reza\", address\"LeninGrad-12345678\", date\"19410908\", info\"do the task\", price\"1.57\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}