const regex = new RegExp('newTask[\\{] taskId\\"(?<id>\\d{1,4})\\", username\\"(?!(?i:bahman\\"))\\w{7,16}\\d\\", isValid\\"(?<isitthough>no|yes)\\", name\\"[\\w\\s]*\\", address\\"(?<address>[\\w\\s]+-\\d{8,10})\\", date\\"(?<date>\\d{8})\\", info\\"(?<info>[^\\"]*)\\", price\\"(?<price>\\d+\\.?\\d*)\\"', 'gm')
const str = `newTask{ taskId"1", username"AyesItsGoood4", isValid"yes", name"reza", address"LeninGrad-12345678", date"19410908", info"do the task", price"1.57" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}