package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<contry>\w+)$`)
var str = `ww.abcd.hongkong
ww.abcd.cn
ww.abcd.asiaenglish.ph
ww.abc.us
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}