re = /(?<contry>\w+)$/m
str = 'ww.abcd.hongkong
ww.abcd.cn
ww.abcd.asiaenglish.ph
ww.abc.us
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end