using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(mytoken|MYTOKEN)(.*?)\d";
string input = @"mytoken sdfsdf sdf 234";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}