package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(mytoken|MYTOKEN)(.*?)\d`)
var str = `mytoken sdfsdf sdf 234`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}