import re
regex = re.compile(r"^[^AEIOU]$", flags=re.MULTILINE)
test_str = ("A\n"
"B\n"
"C\n"
"D\n"
"E\n"
"F\n"
"G\n"
"H\n"
"I\n"
"J\n"
"K\n"
"L\n"
"M\n"
"N\n"
"O\n"
"P\n"
"Q\n"
"R\n"
"S\n"
"T\n"
"U\n"
"V\n"
"W\n"
"X\n"
"Y\n"
"Z\n"
" \n"
"!\n"
"?\n"
"7")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")