import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,23}[\\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}[\\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}$";
final String string = "Qəüöğ Üddsfs Üeredgd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}