re = /^[ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,23}[\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}[\s][ABCÇDEƏFGHXİJKQLMNOÖPRSŞTUÜVYZ]{1}[abcçdeəfgğhxıijkqlmnoöprsştuüvyz]{2,15}$/
str = 'Qəüöğ Üddsfs Üeredgd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end