import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Za-åa-ö 0-9/%!\\\"#¤%&/()=?\\¨'\\[\\]@£$|§_<>.,-]";
final String string = " 31.10.2012 20940,00 Sociallnämnden Gullbergs Plåtslageri Automatkonterade överföringar Specsavers / Aqua Drop 1X10ml˜Bottle - Pack of 12";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}