# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b\w+.*\b).*(\1)//gm;t' <<< "jack johnny - mary joe ken johnny bill
jack jack
Jackie Chan fought The Dragon who was fighting Jackie Chan"