import Foundation
let pattern = #"(\b\w+.*\b).*(\1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
jack johnny - mary joe ken johnny bill
jack jack
Jackie Chan fought The Dragon who was fighting Jackie Chan
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)