#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/*.mkv"
Local $sString = "folder.jpg" & @CRLF & _
"metadata" & @CRLF & _
"Stargate SG-1 S01E01-E02 Children of the Gods.mkv" & @CRLF & _
"Stargate SG-1 S01E03 The Enemy Within.mkv" & @CRLF & _
"Stargate SG-1 S01E04 Emancipation.mkv" & @CRLF & _
"Stargate SG-1 S01E05 The Broca Divide.mkv" & @CRLF & _
"Stargate SG-1 S01E06 The First Commandment.mkv" & @CRLF & _
"Stargate SG-1 S01E07 Cold Lazarus.mkv" & @CRLF & _
"Stargate SG-1 S01E08 The Nox.mkv" & @CRLF & _
"Stargate SG-1 S01E09 Brief Candle.mkv" & @CRLF & _
"Stargate SG-1 S01E10 Thor's Hammer.mkv" & @CRLF & _
"Stargate SG-1 S01E11 The Torment of Tantalus.mkv" & @CRLF & _
"Stargate SG-1 S01E12 Bloodlines.mkv" & @CRLF & _
"Stargate SG-1 S01E13 Fire and Water.mkv" & @CRLF & _
"Stargate SG-1 S01E14 Hathor.mkv" & @CRLF & _
"Stargate SG-1 S01E15 Singularity.mkv" & @CRLF & _
"Stargate SG-1 S01E16 Cor-Ai.mkv" & @CRLF & _
"Stargate SG-1 S01E17 Enigma.mkv" & @CRLF & _
"Stargate SG-1 S01E18 Solitudes.mkv" & @CRLF & _
"Stargate SG-1 S01E19 Tin Man.mkv" & @CRLF & _
"Stargate SG-1 S01E20 There But For the Grace of God.mkv" & @CRLF & _
"Stargate SG-1 S01E21 Politics (1).mkv" & @CRLF & _
"Stargate SG-1 S01E22 Within the Serpent's Grasp (2).mkv" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")