import re
regex = re.compile(r"/*.mkv")
test_str = ("folder.jpg\n"
"metadata\n"
"Stargate SG-1 S01E01-E02 Children of the Gods.mkv\n"
"Stargate SG-1 S01E03 The Enemy Within.mkv\n"
"Stargate SG-1 S01E04 Emancipation.mkv\n"
"Stargate SG-1 S01E05 The Broca Divide.mkv\n"
"Stargate SG-1 S01E06 The First Commandment.mkv\n"
"Stargate SG-1 S01E07 Cold Lazarus.mkv\n"
"Stargate SG-1 S01E08 The Nox.mkv\n"
"Stargate SG-1 S01E09 Brief Candle.mkv\n"
"Stargate SG-1 S01E10 Thor's Hammer.mkv\n"
"Stargate SG-1 S01E11 The Torment of Tantalus.mkv\n"
"Stargate SG-1 S01E12 Bloodlines.mkv\n"
"Stargate SG-1 S01E13 Fire and Water.mkv\n"
"Stargate SG-1 S01E14 Hathor.mkv\n"
"Stargate SG-1 S01E15 Singularity.mkv\n"
"Stargate SG-1 S01E16 Cor-Ai.mkv\n"
"Stargate SG-1 S01E17 Enigma.mkv\n"
"Stargate SG-1 S01E18 Solitudes.mkv\n"
"Stargate SG-1 S01E19 Tin Man.mkv\n"
"Stargate SG-1 S01E20 There But For the Grace of God.mkv\n"
"Stargate SG-1 S01E21 Politics (1).mkv\n"
"Stargate SG-1 S01E22 Within the Serpent's Grasp (2).mkv\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")