use strict;
my $str = '01001
11010
23034
34567
2343
45678
56786
67896
7856
8990
89999
999999
9741
9751
9761
9771
9781
9791
9811
9821
9831
9841
9851
9861
98l1
1000
29098
78999
98899
98900';
my $regex = qr/^([0-8]\d{4}|97[0-6]\d{2}|98[06-9]\d{2}|9[0-69]\d{3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}