re = /^([0-8]\d{4}|97[0-6]\d{2}|98[06-9]\d{2}|9[0-69]\d{3})$/m
str = '01001
11010
23034
34567
2343
45678
56786
67896
7856
8990
89999
999999
9741
9751
9761
9771
9781
9791
9811
9821
9831
9841
9851
9861
98l1
1000
29098
78999
98899
98900'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end