const regex = /(?<!java:)\b\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!java:)\\b\\d+', 'g')
const str = `(SomeName.java:470) This is the 1st string out of a total of 50 string:345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}