$re = '/(?<!java:)\b\d+/';
$str = '(SomeName.java:470) This is the 1st string out of a total of 50 string:345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);