$re = '/^.*where=([a-zA-Z]*).*cat=([^&]*).*|.*cat=([^&]*).*where=([a-zA-Z]*).*$/';
$str = 'https://www.pickupmyjunkcar.com/cardetails/?id=153&slug=1996-buick-century--in-indianapolis-indiana';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);