re = /^.*where=([a-zA-Z]*).*cat=([^&]*).*|.*cat=([^&]*).*where=([a-zA-Z]*).*$/
str = 'https://www.pickupmyjunkcar.com/cardetails/?id=153&slug=1996-buick-century--in-indianapolis-indiana'
# Print the match result
str.match(re) do |match|
puts match.to_s
end