$re = '/^(?:Mrs?|Ms|[DE]r)\.\s*[A-Za-z]/m';
$str = 'Mr. Abc
Mrs.Abc
Ms. Abc
Dr. Abc
Er. Abc';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;