$re = '/(^|\s)(processtest)(\s|$)/i';
$str = 'This is ProCeSSTesT or processTester or PROCESSTEST preprocessTeSt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);