re = /(^|\s)(processtest)(\s|$)/i
str = 'This is ProCeSSTesT or processTester or PROCESSTEST preprocessTeSt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end