const regex = /[\w]*(?=,)|(?<=and )[\w]*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w]*(?=,)|(?<=and )[\\w]*', 'gmi')
const str = `these 13 keys are 4, C1, C2, 11, 12, 26, 54, 70, 75, 80, 87, 89, and 95 some other 2 text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}