$re = '/[\w]*(?=,)|(?<=and )[\w]*/mi';
$str = 'these 13 keys are 4, C1, C2, 11, 12, 26, 54, 70, 75, 80, 87, 89, and 95 some other 2 text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);