import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ix) \n"
+ "(\\w+)\\ (semaine|jours)?\n"
+ "|\n"
+ "(demain|ce soir|aujourd'hui|\n"
+ "(next|this)[\\ \\b](matin|après-midi|soir|Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)\n"
+ ")|(Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)\n"
+ "|\n"
+ "(janvier|février|Mars|Avril|Mai|Juin|Juillet|Août|Septembre|Octobre|Novembre|Décembre)\\ (\\w+)((\\s|\\-)?\\w*)\n";
final String string = "quelle sera la température dans cinq jours\n"
+ "c'est quoi la température pour aujourd'hui\n"
+ "Comment fera-t-il lundi prochain?\n"
+ "quelle est la température ce soir?\n"
+ "donne-moi la température pour demain matin\n"
+ "quelle sera la température dans 8 semaines\n"
+ "température cet après-midi\n"
+ "température lundi prochain\n"
+ "What is the weather for march 8\n"
+ "What is the weather for march twenty-second";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}