re = /^(?=.*?\bcat\b)(?!.*?\bdog\b).*$/m
str = 'My pet: parrot
My pet: dog and cat
My pet: cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end