import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "puppet(.*?)::";
final String string = "chocolatey\n"
+ "pe_install::install\n"
+ "pe_postgresql::lib::devel\n"
+ "profile::agent_config\n"
+ "puppet_agent::install::remove_packages\n"
+ "puppet_customer::customer_shared::alerts\n"
+ "puppet_customer::email_shared::email\n"
+ "puppet_edcs::claims::grt_api\n"
+ "puppet_enterprise::certs::puppetdb_whitelist\n"
+ "puppet_ets::windows::defaults::audit_policy\n"
+ "puppet_metrics_collector\n"
+ "puppet_policyservicing::owbinet::file_cluster\n"
+ "puppet_printserver::print\n"
+ "puppet_product::avrt::avrt\n"
+ "puppet_quoting::aqw_dca::aqw\n"
+ "puppet_testing::ourtestfile\n"
+ "puppet_webpresence::lifelanes_webapp\n"
+ "role::customer::customer_shared";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}