import re
regex = re.compile(r"puppet(.*?)::", flags=re.MULTILINE)
test_str = ("chocolatey\n"
"pe_install::install\n"
"pe_postgresql::lib::devel\n"
"profile::agent_config\n"
"puppet_agent::install::remove_packages\n"
"puppet_customer::customer_shared::alerts\n"
"puppet_customer::email_shared::email\n"
"puppet_edcs::claims::grt_api\n"
"puppet_enterprise::certs::puppetdb_whitelist\n"
"puppet_ets::windows::defaults::audit_policy\n"
"puppet_metrics_collector\n"
"puppet_policyservicing::owbinet::file_cluster\n"
"puppet_printserver::print\n"
"puppet_product::avrt::avrt\n"
"puppet_quoting::aqw_dca::aqw\n"
"puppet_testing::ourtestfile\n"
"puppet_webpresence::lifelanes_webapp\n"
"role::customer::customer_shared")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")