const regex = /(^|\s)a(?=\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)a(?=\\s|$)', 'gm')
const str = `a a a a`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);